Getting Data In

Heavy forwarder isn't forwarding data from UDP port to indexer


Hello team, I have a HF in place and it is supposed to listen to a UDP port and forward the data to the indexer. Its confirm the netstat shows UDP port open and also network Team confirms for the port receiving data. But the splunk below configurations are not successful:

disabled = 0

having indexer conf

splunkd.log shows only one entry for port as
INFO TcpInputProc - Closing raw IPv4 port 1049

Please help on this to make the instance listen to UDP port.

0 Karma

Super Champion

You can configure Splunk to listen on a > 1024 port and use Linux's iptables to do port redirection.

For example, configure in inputs.conf: [udp:1049]

And put into your iptables config:

iptables -t nat -A PREROUTING -p udp --dport 514 -j REDIRECT --to-port 1049

Also check conncetion between forwarder and receiver
Refer this link:

you need to enable forwarder receiving port on indexer :
refer this link to do the same:

Let me know if this helps!

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...