Getting Data In

Disable the Universal Forwarder Clients

tlow
Explorer

what is the best ways to disable the universal Forwarder Clients sending data to the indexer.

I tried deploying an apps with inputs.conf

[default]
disabled=1

to disable all inputs, so there is no data sending the indexer.

or could change the outputs.conf on the client using deployment server

want to able to disable the UF clients.

lguinn2
Legend

I think the easiest way to do this will be to disable the apps on the forwarders. On the deployment server, edit app.conf for each of the apps that are distributed to the UFs, adding the following

[install]
state = disabled

Then reload the deployment server so it will distribute the updated/disabled app to all the forwarders.

A disabled app is completely ignored, so this effectively disables all the inputs.conf and outputs.conf that are configured in apps. The only risk may be any UFs that have set inputs or outputs in etc/system/local - hopefully there are none of those in your environment.

tlow
Explorer

This stanza doesn't work, tried on UF 6.1.1 and Indexer 6.1.1

data still coming to indexer after pushed out the app, checked is on the UF client and restart the UF client but still getting data to the indexer

And this only disabled a particular apps in UF? IU?

i want to disable UF if it sending too much data or a least able to turn on/off as needed.

0 Karma
Get Updates on the Splunk Community!

Your Guide to SPL2 at .conf24!

So, you’re headed to .conf24? You’re in for a good time. Las Vegas weather is just *chef’s kiss* beautiful in ...

Get ready to show some Splunk Certification swagger at .conf24!

Dive into the deep end of data by earning a Splunk Certification at .conf24. We're enticing you again this ...

Built-in Service Level Objectives Management to Bridge the Gap Between Service & ...

Now On-Demand Join us to learn more about how you can leverage Service Level Objectives (SLOs) and the new ...