Getting Data In

CLI "list forwarder" does not show all active forwarder when enabling load balance.

Shuhei052492
Path Finder

Hello Splunk professional,

I would like to know how to work the CLI command "splunk list forward-server" in Universal Forwarder which is enabled load balance.
In my opiniton, I wonder that Active forwards would be showed two indexer IP addresses. while there is just one IP address of indexer which is returned as result by the CLI command "splunk list forward-server" , and there is another indexer IP address in "Configured but inactive forwards:".

Is it correct result?
Also what is the best way to enable "load balance" in UF if it is not showed all in "Active forwards:".

I appreciate any advice.

Best regards,

0 Karma

spavin
Path Finder

Hi @Shuhei052492,

What you are seeing means you have set up forwarding correctly.

The universal forwarder has 2 indexers set up, and it will automatically load balance between them.

By default, it will send to one indexer for 30 seconds, then switch to the other for 30 seconds, then back to the first. It will only send data to one indexer at a time.

You can test this out by running splunk list forward-server then waiting 35 seconds, then running it again.

You can also configure the forwarders to load balance based on data volume, to try to get an even spread of data in your indexers.

Check out the docs here:
https://docs.splunk.com/Documentation/Splunk/7.2.4/Forwarding/Setuploadbalancingd

.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!