Developing for Splunk Enterprise
Highlighted

Splunk ML toolkit, Python Scientific Computing : pasty package version upgrade issue

New Member

Hello, I am writing a custom algorithm for fitting a GLM model for Negative Binomial using the latest versions of Splunk ML toolkit and Python for Scientific Computing on Splunk Enterprise (local).

I encountered this issue:

"ValueError: For numerical factors, num_columns must be an int"

I researched a bit and found out that this is because of the 'pasty' package version 0.4 that comes with scipy. It occurs on Windows 64 bit.

The solution is to upgrade the 'pasty' package to higher version. How do I upgrade this with the Python for Scientific Computing/ML Toolkit in Splunk?

On a related note, how do I check what versions of scipy/other packages are being used in Python for Scientific Computing 1.2?

0 Karma
Highlighted

Re: Splunk ML toolkit, Python Scientific Computing : pasty package version upgrade issue

New Member

Hi,

you can see all the package versions in the readme file in the app folder:

  • numpy 1.10.4
  • scipy 0.17.0
  • pandas 0.17.1
  • scikit-learn 0.17.0
0 Karma