Deployment Architecture

java bridge fails to reload after db input changes


Hi all!

I’m totally confused with Splunk DB connect java bridge behavior.
We have : a search head, two indexers (distributed search, not clustering, Splunk 6.2.0, CentOS 6.6)
Db connect is on the searchhead. I use jre-8u31-linux-x64.gz (used also jre-7u76-linux-x64.gz with the same result) and ojdbc6.jar as Oracle database driver. Connection to a database works. I can see the tables and query a database. Database input works (more or less).
The problem with the Java bridge fails to reload after enable/disable (or changing) database inputs in web-interface. Splunk web shows “java bridge reloading”. Nothing special in jbridge.log. The last line of dbx.log is about checking Jbridge status:


And no record about SystemStatus return (status=0 when everything works). I can't control inputs and DB connect stops log recording. When I kill (kill -KILL PID) java process then a new java thread appears everythithg seeems to work until next reload (enable/disable data input).

Some other symptoms:
1. When I disable/ enable db inputs from web-console and make some browsing through db connect web-controls I got the splunk web interface frozen and “Your network connection may have been lost or Splunk web may be down.” error on top of it.
2. Restarting splunkd to make splunk web alive is extremely slow in this case
3. The truth is that splunk-web actually alive, but doesn't respond to the browser requests
4. The way to return to splunk-web is to clean session cookies (but you still need to kill java PID to gain control over db connect app).

So …I can’t manage my database inputs in this manner. I reinstalled db-connect – no effect. I tried the similar scenario in my test environment (CentOS release 6.4 (Final)) – and it works there!!

Is anyone had the similar problems? I’ve seen an answer with the similar issue:
*Splunk DB connect: The java bridge is: loading.... (#146939) * - cann't post links here
We also use both Splunk and LDAP authentication, but I do not see any connection between my splunk admin account and implemented LDAP auth.
Please, help!

0 Karma

Splunk Employee
Splunk Employee

Java 8 still isnt supported in DBConnect, so downgrade to 1.7. I'd also check on your system and see which version of Java is active. You may need to install more the the JRE..

On centos, you can use the 'alternatives' command ala 'alternatives --config java' and it will let you choose which version of java the system will use.

0 Karma


Thanks! As a mentioned different java versions. And I have the only version currently working - the version I unstalled for java bridge. Dbx.log and jbridge.log shows nothing interesting in debug mode.
I cann't afford more time for it and will ask a customer for re-install splunk.

0 Karma
Get Updates on the Splunk Community!

Take the 2021 Splunk Career Survey for $50 in Amazon Cash

Help us learn about how Splunk has impacted your career by taking the 2021 Splunk Career Survey. Last year’s ...

Using Machine Learning for Hunting Security Threats

WATCH NOW Seeing the exponential hike in global cyber threat spectrum, organizations are now striving more for ...

Observability Newsletter Highlights | March 2023

 March 2023 | Check out the latest and greatestSplunk APM's New Tag Filter ExperienceSplunk APM has updated ...