Deployment Architecture

adhoc_searchhead is not working in search head cluster

nisu
Explorer

I have added the following setting in one of the search head to disable scheduled search.

[shclustering]
adhoc_searchhead = true 

After adding this, When I visit the "Jobs" tab there are so many savedsearches are in running mode and some are completed. Not able to stop running scheduled search.

0 Karma

jcrabb_splunk
Splunk Employee
Splunk Employee

The Jobs page will show all jobs executed by the Search Head Cluster, not just the local instance. If you applied the setting and restarted, the cluster, the setting should be in effect. If you use the DMC -or- Monitoring console you should be able to determine if the instance is running any scheduled searches or check the scheduler.log on the instance.

Jacob
Sr. Technical Support Engineer
0 Karma
Get Updates on the Splunk Community!

Splunk Training for All: Meet Aspiring Cybersecurity Analyst, Marc Alicea

Splunk Education believes in the value of training and certification in today’s rapidly-changing data-driven ...

The Splunk Success Framework: Your Guide to Successful Splunk Implementations

Splunk Lantern is a customer success center that provides advice from Splunk experts on valuable data ...

Investigate Security and Threat Detection with VirusTotal and Splunk Integration

As security threats and their complexities surge, security analysts deal with increased challenges and ...