Deployment Architecture

When editing app properties in my Splunk SHC as an admin, why am I getting a "You do not have permissions to edit this configuration." banner?

tnerpel_splunk
Splunk Employee
Splunk Employee

(creating this to answer)

Details:

Search Head Cluster (SHC)
v6.5.2
Logged in as admin

When going to manage apps and then clicking Edit properties the edit page opens, but has a red "You do not have permissions to edit this configuration." banner at the top of the page. There is no save button, only a cancel option.

1 Solution

tnerpel_splunk
Splunk Employee
Splunk Employee

This is expected behavior in a SHC environment. If you need to edit any properties, you should do it at the Deployer level and then push the shcluster-bundle down to the members. This is to keep apps from behaving differently or having different settings and properties inside of the SHC.

View solution in original post

jmclean
Engager

So why would the "Edit properties" link be there at all? If it was simply a method of viewing the properties it should be renamed to "View properties".

tnerpel_splunk
Splunk Employee
Splunk Employee

This is expected behavior in a SHC environment. If you need to edit any properties, you should do it at the Deployer level and then push the shcluster-bundle down to the members. This is to keep apps from behaving differently or having different settings and properties inside of the SHC.

View solution in original post

jmclean
Engager

So then that link should be renamed from "Edit properties" to "View properties".

0 Karma

AnilPujar
Path Finder

how to disable default search app?

do i need to push search app also from deployer? after editing app.conf?

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!