Deployment Architecture
Highlighted

Splunk 5 Clustering: Indexes not seen In clustering dashboard on the master node

Splunk Employee
Splunk Employee

When looking at the clustering dashboard on the master node, only see the default indexes are listed in the index details: (summary, _audit and _internal). Customer created indexes are not visible.

Highlighted

Re: Splunk 5 Clustering: Indexes not seen In clustering dashboard on the master node

Splunk Employee
Splunk Employee

The problem was caused by the fact that repfactor attribute was not set to "auto" for the newly added indexes in the peers indexes.conf.

repFactor=auto is set automatically for the default indexes when you enable clustering, but new indexes that you wish to replicate have to be configured manually.

See http://docs.splunk.com/Documentation/Splunk/5.0/Indexer/Configurethepeerindexes for full information

View solution in original post

Highlighted

Re: Splunk 5 Clustering: Indexes not seen In clustering dashboard on the master node

Contributor

Also - customer created indexes don't show up in the clustering dashboard until there is an event in them! This confounded me for hours one day until I decided to send some data to the index, and lo and behold, as soon as there was a hot bucket for the index on one of my indexers, it immediately shows up in the clustering dashboard.

Highlighted

Re: Splunk 5 Clustering: Indexes not seen In clustering dashboard on the master node

Motivator

Probably just to do with how the dashboard searches are created. The only way around it is to have a savedsearch csv populating lookup which is then called in the dashboard. This way you can show empty indexes.

0 Karma