Deployment Architecture
Highlighted

Search head pooling error

Communicator

I'm trying to setup search head pooling. I've followed the directions listed here

But when I startup splunkd I get an error. Here is the stack trace:

2011-03-22 12:28:43,565 ERROR   [4d88ea5b361b339410] root:491 - Unable to start splunkweb
2011-03-22 12:28:43,565 ERROR   [4d88ea5b361b339410] root:492 - Illegal escape from parent directory "/splunkconfig/pooledheads/": /splunkconfig/pooledheads/etc/apps
Traceback (most recent call last):
  File "/opt/splunk/lib/python2.6/site-packages/splunk/appserver/mrsparkle/root.py", line 487, in <module>
    run(blocking=True)
  File "/opt/splunk/lib/python2.6/site-packages/splunk/appserver/mrsparkle/root.py", line 324, in run
    mount_static(ctrl, global_cfg, cfg)
  File "/opt/splunk/lib/python2.6/site-packages/splunk/appserver/mrsparkle/root.py", line 161, in mount_static
    static_app_dir= make_absolute('etc/apps', '')
  File "/opt/splunk/lib/python2.6/site-packages/splunk/appserver/mrsparkle/lib/util.py", line 194, in make_absolute
    fullpath = make_splunkhome_path_helper(fragment)
  File "/opt/splunk/lib/python2.6/site-packages/splunk/appserver/mrsparkle/lib/util.py", line 384, in make_splunkhome_path_helper
    (basepath, fullpath))
ValueError: Illegal escape from parent directory "/splunkconfig/pooledheads/": /splunkconfig/pooledheads/etc/apps

I configured pooling with this command:

/opt/splunk/bin/splunk pooling enable /splunkconfig/pooledheads/ --debug

Any ideas?

Tags (1)
Highlighted

Re: Search head pooling error

Communicator

According to Splunk support this is a bug with the version I'm using. The solution is to leave the trailing slash off the NFS path. e.g.

/opt/splunk/bin/splunk pooling enable /splunkconfig/pooledheads --debug

View solution in original post