Deployment Architecture
Highlighted

How to disable a deployment server after switching from a Splunk Enterprise trial license to the free license?

Explorer

Hi folks,

When I click on "Settings -> Data inputs" I'm getting "500 Internal Server Error".

The log file $SPLUNKHOME/var/log/splunk/webservice.log displays the following information:

InternalServerError: [HTTP 500] Splunkd internal error; [{'type': 'ERROR', 'code': None, 'text': "\n In handler 'http': Deployment Server is not available, because errors prevented its initialization. Please consult splunkd.log for details. You can try to reload Deployment Server after correcting these errors."}]

I've tried to disable deployment server, but unsuccessfully:

$ splunk disable deploy-server
Current license does not allow the requested action

Also I've tried configured this on $SPLUNK_HOME/etc/system/local/serverclass.conf:

[global]
disabled = true

And then I've restarted Splunk, but the same issue occurs.

Any suggestions will be appreciated.

Thank you!!
Jorge.

Highlighted

Re: How to disable a deployment server after switching from a Splunk Enterprise trial license to the free license?

Splunk Employee
Splunk Employee

Deployment server is not available with the free license.

Check to see if the splunk_httpinput app is disabled on the indexer (it should be enabled).

There are other reports of the same issue (with no clear resolution), see this related Answers posting.

0 Karma
Highlighted

Re: How to disable a deployment server after switching from a Splunk Enterprise trial license to the free license?

Explorer

The Deployment Server was enabled on this installation because it was configured when using Trial Enterprise license.

Now, the Trial Enterprise license has expired and the Deployment server has stopped working and can't be disabled.

0 Karma