Deployment Architecture

Deploying an app causes splunkweb.exe on deploy client to switch on. How to stop this?

Motivator

Hey,

Whenever I deploy application App_1 across my Indexers, the application deploys successfully however the splunkweb.exe service on each of these servers is switched back on. As these servers are used for indexing only, the splunkweb.exe service does not need to run on these servers.

Is there an attribute in my config below (taken from serverclass.conf) that can be used to prevent the splunkweb.exe service from starting each time a deployment is executed? restartSplunkWeb=false does not seem to achieve this.

[serverClass:All-Configs]
whitelist.0 = Indexer*

[serverClass:All-Configs:app:App_1]
stateOnClient=enabled
restartSplunkd=true
restartSplunkWeb=false

Thanks in advance for your help.

0 Karma
1 Solution

Legend

splunkweb is turned off by setting the following in web.conf:

[settings]
startwebserver = 0

View solution in original post

0 Karma

Legend

splunkweb is turned off by setting the following in web.conf:

[settings]
startwebserver = 0

View solution in original post

0 Karma

Motivator

Hi Ayn, if I add this to web.conf and then try to run splunk restart splunkweb or splunk start splunkweb in the CLI will these commands turn splunkweb on OR will this setting in web.conf override any attempts to turn on splunkweb? Thanks

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!