Deployment Architecture

Cannot push new index cluster bundle after rollback

zayers2
Explorer

I recently had to rollback a config bundle file on our index master running windows server 16.

Now I every time i try to push the updated bundle I get this error:

Recent rollback bundle operation failed to remove contents under path=C:\Program Files\Splunk\etc\master-apps. Please untar active bundle manually from bundle=[id=DEDFCEB031E7377224B4E3EBCD
608C80, path=C:\Program Files\Splunk\var\run\splunk\cluster\remote-bundle\d52190c329a27ebe07129537c6adbd76-1541522317.bundle] onto path=C:\Program Files\Splunk\etc\master-apps and delete dirty marker file=C:\Program Files\Splunk\etc\master-apps.dirty in order to proceed with new config bundle push.

I am not able to find the master-apps.dirty that they are reffering to, and I have tried restarting the index master with no luck.

What should I do to correct this error?

vinkumar_splunk
Splunk Employee
Splunk Employee

I suppose you need to just take out the file from that folder and try again that would help.

d52190c329a27ebe07129537c6adbd76-1541522317.bundle

bambarit
Explorer

I have same issue, have you fix it?

0 Karma

boromir
Path Finder

I had a similar issue. It started as normal push for a new Index configuration, however it was not pushed towards all indexers. My next moves might not have been the best, but I tried a Rollback, failing with the same error. Master app directory on the CM was empty.

 

Once it failed all other push configurations failed with one and the same message as the one in the thread.

The solution was the one proposed in the message , and it worked. However it was reassuring to have the directories back-uped first.

Tags (1)
0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!