Dashboards & Visualizations

Why Splunk doesn't index all the lines in a monitored file?

andrei_radu
New Member

Hello,

I use Splunk Universal Forwarder 6.3.4 on a centralized syslog collector and it's set to monitor a folder populated with symbolic links. (inputs.conf content below).

[monitor:///service/rsyslog/splunk/critical_systems/]
followSymlink = true
host_segment=5
sourcetype = critical_unix
index = critical_systems

Everything went good until i noticed that not all the lines inside the monitored files are being indexed. I'm not filtering anything with props.conf and transforms.conf. There's no pattern for the lines that are skipped, everything is random.

Any idea why this is happening and how to fix it?

Thanks!

0 Karma

andrei_radu
New Member

I found my problem. There were 2 different apps monitoring the same location, sending data to different indexes. So logs went randomly into only one index. Disabled one of the apps and now everything looks fine.

0 Karma

ddrillic
Ultra Champion

When we index, we make an assumption that the Splunk time stamp process works well.

We see here an example where this process didn't work as expected - Can't index new data..? :S

It says -

alt text

0 Karma

lguinn2
Legend

Do you see any messages in $SPLUNK_HOME/var/log/splunk/splunkd.log? In particular, I would look at this log file on the forwarder

0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...