Dashboards & Visualizations

Splunk Cluster Map showing only 10 colour marker, after that it shown on 1 repeated color.


I tried setting up cluster map, I have 93 country codes to display. However, the map shows only 10 colors and after that it shows only repeated Violet color. Further, I have used "| geostats latfield=Lat longfield=Long count by Country" count by country and it show's only 10 countries and for other countries it shows "Others".Capture.JPG

Labels (4)
0 Karma


Try adding the globallimit= field to geostats. As in:

| geostats globallimit=93 latfield=Lat longfield=Long count by Country


0 Karma


Hello @kgiri253 ,

While using geostats, you might want to increase the globallimit parameter value which would not club the other countries into OTHER field. You can set it's value to any integer as per the requirement. And if you wish to display all the results, you can set the value to 0. 

Here's the documentation link for the same - https://docs.splunk.com/Documentation/SplunkCloud/9.1.2312/SearchReference/Geostats




If the above solution helps, an upvote is appreciated.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...