Dashboards & Visualizations

Search Help combine with Dashboard

coric
Engager

Here's my challenge,

I've got multiple same IP with Different Attack_type categories,

I'm trying to combine all the same IP  together and make a chart that shows the Attack_type and just 1 IP

 

Something like this but a dashboard that list out what IP is associated to all the different Attack_type 

 

 

Labels (3)
Tags (1)
0 Karma

jhanvidattani
Path Finder

@coric 

You can try the below thing to handle this. It will give the latest value of Attack_type for given ip_adddress.

| stats first(Attack_Type) count as Count by ip_address

 If you are using tstats command and Data model, then you can also go for the below thing:

| tstats summariseonly=<keep_it_configurable> latest(<data_model>.Attack_type) from datamodel=<> by <data_model>.ip_address


 If you find my solution fruitful, then an upvote would be appreciated.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...