Dashboards & Visualizations

Query for processes status from multiple hosts

splunker_ind
Loves-to-Learn

Hi Splunkers, 

I have a 2 hosts i.e server1 & server2.

Each host running with multiple processes. Lets say the processes are process1 & process2.

I want to create a dashboard to show the latest processes status whether it is Running or Not Running in each host

 

index=os host IN (server1 server2)  ARGS=*process1* OR ARGS=*process2*
| eval process1_status=if(like(ARGS,"%process1%"),"Running","Not Running")
| eval process2_status=if(like(ARGS,"%process2%"),"Running","Not Running")
| stats latest(process1_status)  latest(process2_status)  by host
| fillnull value=NULL

But this query is not giving correct results.

Each event will have either ARGS field as process1 or ARGS field as process2.

 

 

Labels (3)
0 Karma

splunker_ind
Loves-to-Learn

I used join command which works fine but it takes time.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...