Dashboards & Visualizations
Highlighted

How to troubleshoot why I am unable to pass a token from the URL when drilling down to an HTML dashboard?

Explorer

hay all,

Trying to do a drill down to an html dashboard....I've been unable to get a token value working if its in the html i.e

<h4>Video Drilldown : $foo$ </h4> where the URL has ?foo=bar does NOT set the value....
I've looked at the example here and it doesn't seem to suggest anything extra to make tokens work in the HTML.... http://dev.splunk.com/view/SP-CAAAEVW ... I also found this Splunk Answers post that's specific to Splunk 6.1 ... I'm on 6.5 and seeing this issue with the token not being substituted....
https://answers.splunk.com/answers/112509/simple-xml-token-not-substituted-within-href-attribute.htm...

Also to note, every other search on the dashboard (which was a Simple XML > HTML converted dashboard) is populated with a token from the URL and it works fine....

Even looked at the example here http://dev.splunk.com/view/SP-CAAAEVW & previous questions on a bug with Splunk 6.1 here https://answers.splunk.com/answers/112509/simple-xml-token-not-substituted-within-href-attribute.htm...

Essentially, no matter where I put the token in the html, it is not converted to its string that is contained in the URL bar.

0 Karma
Highlighted

Re: How to troubleshoot why I am unable to pass a token from the URL when drilling down to an HTML dashboard?

Explorer

Changed back to a form view with embedded HTML section & set the tokens in the dashboard using conditional evals from the drilldown base search

View solution in original post

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.