Dashboards & Visualizations

How to hide error message icons from dashboard?

Path Finder

hello there

I want to hide the error icons on my dashboard. Is that possible?
alt text


Path Finder

Add this to the Simple XML:

  <row depends="$alwaysHideHTMLStyle$">
           .dashboard-row .dashboard-panel .error-details .error-indicator {
            display: none; !important;

As woodcock says, this should be used with caution. I only use it for end-user dashboards where display would be more confusing than not (in my case we're getting a bunch of warnings that the query initialization time is longer than a second because the storage is slow). Power User dashboards still show the errors.


Hi @Kenshiro70

Thank you.This code is working fine.
This code hides the error icons for everyone.
But pls let me know if you have any idea if we can hide these icon for basic users only and not for power users.
or if we can differentiate between warning icons and red error icons and hide only warning icons.
Power users wants to see those errors.

0 Karma


Great answer. Thank you!

0 Karma

Esteemed Legend

I am pretty sure that there is no way to hide them and, IMHO, you should not. They are deliberately placed there to let you, the consumer of the data, know that there is a system problem that could possibly be effecting the accuracy of the data in the panel that you are viewing. This is actually VERY important to know. The right way to handle it is to clear the error so it goes away, not hide it. It is kind of like saying "my wife is sick of my check engine light flashing; how can I disable it other than covering it up with black tape?"

0 Karma


Based on these link :

First you need to check that your csv file - "Kunden" is clean and there is no hidden character.
Second, bsed on link 1--try reversing the order of fields in AS. If you have mentioned such in props.conf

0 Karma


Can you share the error message which displays after clicking the icon.
Once this icon showed me lookup error . I added the lookup file (mentioned in error message) in Lookup Definition and it worked.
See if its the same case for you.

0 Karma

Path Finder

the error is
" Error 'Could not find all of the specified lookup fields in the lookup table.' for conf 'oraclemonitoring' and lookup table 'Kunden'."
I already did what you mentioned.

0 Karma
Get Updates on the Splunk Community!

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...

Using the Splunk Threat Research Team’s Latest Security Content

REGISTER HERE Tech Talk | Security Edition Did you know the Splunk Threat Research Team regularly releases ...

SplunkTrust | 2024 SplunkTrust Application Period is Open!

It's that time again, folks! That's right, the application/nomination period for the 2024 SplunkTrust is ...