Dashboards & Visualizations

How to hide an app from the home page, but still have access to the views inside the app?

I would like to hide some of my apps from being listed in home page, but I still want to be able to access the views inside those apps...
I tried:

[ui]
is_visible = false

in app.conf. but this configuration disables complete UI access for those apps.

Please help me in achieving this.

Tags (5)
0 Karma
1 Solution

Cam back after a long time to give a clean answer
Using the show_in_nav option in app.conf we can hide an application from getting listed in the home screen application list and top navigation app dropdown.

[ui]
is_visible = 1
show_in_nav = false

View solution in original post

Cam back after a long time to give a clean answer
Using the show_in_nav option in app.conf we can hide an application from getting listed in the home screen application list and top navigation app dropdown.

[ui]
is_visible = 1
show_in_nav = false

View solution in original post

I have found a new solution for my requirement,
in default.xml (etc/apps/myapp/default/data/ui/nav/defaults.xml) we can give the background color for our application's icon in the home page app list... as below...

<nav color="#333333">
  <view name="home" default="true" />
  <view name="flashtimeline" />
</na>

What splunk does is, it will apply the color as a style for that div.. as below... suffixed with a ';'

<div style="background-color:#333333;">

so if we change the xml as below,

 <nav color="#333333;dislpay:none">
          <view name="home" default="true" />
          <view name="flashtimeline" />
        </na>

it will create a dive with below style

<div style="background-color:#333333;dislpay:none;">

and my application id hidden in Splunk Home page

Hi param,

I think that, when the an app is hidden, it is hidden with his views. I refer to this sentences in the Admin Manual:
Visible: Apps with views should be visible. Add-ons, which often do not have a view, should disable the visible property. OR
Visible: Apps containing views should be marked visible.

The following links will help you:

http://docs.splunk.com/Documentation/Splunk/6.2.2/Admin/Managingappconfigurationsandproperties

http://docs.splunk.com/Documentation/Splunk/6.2.2/AdvancedDev/BuildApp

Path Finder

If you are trying to hide it for some, but not all of the users, you can also try to update the permissions of the application to only allow access to a certain user role and remove permissions for all other roles. Then put users that should have access in this group.

Hi ,
Go to Manage apps , click on edit properties of your app and select no Visible , with this , you can access your UI for this app.

0 Karma

hi ngatchasandra.. Thanks for your answer...
It hides the application icon from home page... but i couldn't access the views in that app..
It show
App "my_testApp" does not support UI access. See its app.conf for more information.

Note : Manage apps > edit properties > no visible internally update the app.conf with below contents..

[ui]
is_visible = 0

[launcher]

[package]
check_for_updates = 1
0 Karma

Verify also if you give the pemissions to views that you want to see in this app.

0 Karma

I have edited only the app context..
I have enough permission to open views in tat app.. I could open those views before setting visible=no..
But it still shows the same error message

404 Not Found

Return to Splunk home page
App "my_testApp" does not support UI access. See its app.conf for more information.
View more information about your request (request ID = 551d176a8fc1ba1d0) in Search

This page was linked to from http://localhost:8080/myWar/index.html.
0 Karma

I talk about permissions of views not your own permissions.
But if i understanded you very well, you have opened this views before put visible=NO without error.

0 Karma

🙂 I too talked about my user's permission to access that page..
:( Yes it was I could open that view before setting visible=NO

0 Karma

Please, tell me if you can see all views names of your app context in UI page after put visible=NO!

0 Karma

Yes, The view is listed even after setting visible = NO.
In the url .../splunkApp/en-US/manager/launcher/data/ui/views?
with "Show only objects created in this app context" is checked

0 Karma

Remark that in this page, under Actions , for each view, you can see options Clone|Move|Delete not Open option that allow to open view as dashboard, this is because your app is hidden. If this app become visible=yes, you can see Open option to open your views.

0 Karma

Please, are you understand what i say?

0 Karma

Yes... For my view It shows open|Clone options under Actions.
I clicked on open... It works before setting Visible = No..
But after setting Visible =NO it shows the same error message

404 Not Found

 Return to Splunk home page
 App "my_testApp" does not support UI access. See its app.conf for more information.
 View more information about your request (request ID = 551d176a8fc1ba1d0) in Search

 This page was linked to from http://localhost:8080/myWar/index.html.
0 Karma

Please, tell me if you can see all views names of your app context in UI page!

0 Karma

Yes... I could see all view names

0 Karma

Are you select the your app context in the views page? If this, verify your owner it will take Any value.

0 Karma

Because, i have an app which i created, when i hide this app from home page, i can acces his UI .

0 Karma