Dashboards & Visualizations

How to aggregate data by hour across multiple days

Simon1817
Engager

I am looking at event data.  I can group the data by hour like this:

index=wineventlog EventCode=4740 Caller_Computer_Name=SERVER14 Account_Locked_Out_Name=USER12 | TIMECHART SPAN=1h count BY Caller_Computer_Name

but that gives me an hour for each day, so hundreds of rows.

I want 24 rows.  i.e. I want all events that occur between Midnight and 1am, on any day, in the first row; and then all events between 1am and 2am, on any day, in the second row; and so on.

I've 

Labels (1)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi @Simon1817,

let me understand: you want the sum of the values of each hour of many days, is it correct?

if this is your need, please try something like this:

index=wineventlog EventCode=4740 Caller_Computer_Name=SERVER14 Account_Locked_Out_Name=USER12 
| eval hour=strftime(_time,"%H")
| chart count OVER hour BY Caller_Computer_Name

Ciao.

Giuseppe

View solution in original post

Simon1817
Engager

Exactly that, thank you.

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @Simon1817,

let me understand: you want the sum of the values of each hour of many days, is it correct?

if this is your need, please try something like this:

index=wineventlog EventCode=4740 Caller_Computer_Name=SERVER14 Account_Locked_Out_Name=USER12 
| eval hour=strftime(_time,"%H")
| chart count OVER hour BY Caller_Computer_Name

Ciao.

Giuseppe

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...