Dashboards & Visualizations

HTTP Input data endpoint server cannot be started.

vnguyen46
Contributor

Hello,

On one of couple HFs, I received this error message "HTTP Input data endpoint server cannot be started." when creating a new HTTP Event Collector. Even thought, HTTP record created with a pre-assigned token value, but the token doesn't allow the connection where it's used (F5-VPN appliance in this case).

Anyone had resolved this issue?

Thanks,

0 Karma
1 Solution

PavelP
Motivator

Hello @vnguyen46,

please check this answer: https://answers.splunk.com/answers/345909/how-to-troubleshoot-why-the-url-endpoint-for-http.html

Do you have any related errors in splunkd.log?

View solution in original post

0 Karma

vnguyen46
Contributor

Hi - Splunk TS found the issue where port 8088 is being used by the other process. So, don't put port entry 8088 in your inputs.conf file.

0 Karma

PavelP
Motivator

Hello @vnguyen46,

please check this answer: https://answers.splunk.com/answers/345909/how-to-troubleshoot-why-the-url-endpoint-for-http.html

Do you have any related errors in splunkd.log?

0 Karma

vnguyen46
Contributor

Hi - Splunk TS found the issue where port 8088 is being used by the other process. So, don't put port entry 8088 in your inputs.conf file.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...