Dashboards & Visualizations

HEC not working properly with multiple indexes

miena
Loves-to-Learn Lots

I have an HEC configured as follows:

[http://customer]
disabled = 0
index = index1
indexes = index1, index2, index3, index4
token = <token>
sourcetype = _json

however when I test the endpoint using the command: curl -k -L https://<mysplunkurl>/collector -H 'Authorization: Splunk <token>' -d '{"sourcetype": "local_cURL test", "event":"Test Event For New Index"}'...I get a successful 200 response, but the event doesn't appear under any of the configured indexes.  Is this the correct configuration to send events to multiple indexes? 

Labels (1)
0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @miena,

In HEC configuration "index" parameter sets the default index for events that no index defined as metadata. Since you didn't set index parameter on your test command, the event should go to "index1".

"indexes" parameter sets the permitted indexes for this input. This does not mean it will be duplicated to all indexes.

If this reply helps you an upvote is appreciated.
0 Karma
Get Updates on the Splunk Community!

Welcome to the Future of Data Search & Exploration

You have more data coming at you than ever before. Over the next five years, the total amount of digital data ...

What’s new on Splunk Lantern in August

This month’s Splunk Lantern update gives you the low-down on all of the articles we’ve published over the past ...

This Week's Community Digest - Splunk Community Happenings [8.3.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...