Dashboards & Visualizations

Could you help me format my pie chart?

jip31
Motivator

hello,

I have made a pie chart based on the code below.

I thought it was possible to format it quickly but it doesnt seems to be the case.

index=windows sourcetype="wineventlog:system" SourceName="Disk" (EventCode=7 OR EventCode=11 OR EventCode=51 OR EventCode=52) (Type="Critique" OR Type="Avertissement" OR Type="Erreur") 
| stats count by  EventCode

What is a good process?

To adapt the XML file??

For example, I want to add a legend, to add the name "EventCode" on the label, to add the number value on the label, and to add % in the label:

    <title>Pie chart by EventCode</title>
    <search>
      <query>| loadjob savedsearch="admin:search:FO_DiskHealth_EV_Pie"</query>
      <earliest>-24h@h</earliest>
      <latest>now</latest>
    </search>
    <option name="charting.axisTitleX.visibility">visible</option>
    <option name="charting.axisTitleY.visibility">visible</option>
    <option name="charting.axisTitleY2.visibility">visible</option>
    <option name="charting.chart">pie</option>
    <option name="charting.chart.sliceCollapsingThreshold">0.01</option>
    <option name="charting.drilldown">none</option>
    <option name="charting.legend.placement">right</option>
    <option name="trellis.enabled">0</option>
  </chart>

Could you help me please??

0 Karma
1 Solution

vishaltaneja070
Motivator

Hello @jip31

Could you please check the below link and see if that solves your problem:

link text

View solution in original post

0 Karma

vishaltaneja070
Motivator

Hello @jip31

Could you please check the below link and see if that solves your problem:

link text

0 Karma

jip31
Motivator

Hello
it means that we just can use these options?
charting.chart.sliceCollapsingLabel
charting.chart.sliceCollapsingThreshold
charting.chart.showLabels
charting.chart.showPercent

0 Karma

vishaltaneja070
Motivator

Hello @jip31

Yes that's true, what ever option available on the above link is available only. You can use JS to create dashboard there you can have multiple options.

Up vote the answer if you are satisfied.

0 Karma

jip31
Motivator

ok thanks!!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...