Dashboards & Visualizations

Changing data label font size

jhurtado
Engager

I want to make the numbers that appear within the bars of the dashboard bar chart bigger.
We have a screen that displays the bar chart but the numbers are too small to be seen unless you get closer, is there a way to make them appear bigger? I'm referring to the y-axis numbers that appear inside of the bars.

I was trying to access the source code and see if I could figure it out but so far all I know is that you can make them appear or not,

 "<option name="charting.chart.showDataLabels">all</option>"

vnravikumar
Champion

Hi @jhurtado

Check this

<dashboard>
  <label>barchart</label>
  <row depends="$hide$">
    <panel>
      <html>
        <style>
          #rk g[transform] text {
            font-size:20px !important;
          }
        </style>
      </html>
    </panel>
  </row>
  <row>
    <panel>
      <chart id="rk">
        <search>
          <query>index=_internal |stats count by sourcetype</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
        </search>
        <option name="charting.chart">bar</option>
        <option name="charting.drilldown">none</option>
        <option name="charting.chart.showDataLabels">all</option>
      </chart>
    </panel>
  </row>
</dashboard>

nordinethales
Path Finder

Hello,

Thanks a lot!

It worked for me with Pie Chart label

 

Regards

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...