All Apps and Add-ons

port 8008 not starting on the data collector and many errors related to python and certs.

Path Finder

here's the errors see:
nt
05-27-2018 16:44:20.359 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstraphydragateway.py" IOError: [Errno 22] Invalid argument
05-27-2018 16:44:20.359 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstraphydragateway.py" ctx.loadcertchain(self.sslcertificate, self.sslprivatekey)
05-27-2018 16:44:20.358 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstrap
hydragateway.py" File "/opt/splunk/lib/python2.7/site-packages/cherrypy/wsgiserver/init.py", line 1765, in bind
05-27-2018 16:44:20.358 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstrap
hydragateway.py" self.bind(af, socktype, proto)
05-27-2018 16:44:20.357 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstrap
hydragateway.py" File "/opt/splunk/lib/python2.7/site-packages/cherrypy/wsgiserver/init.py", line 1717, in start
05-27-2018 16:44:20.357 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstrap
hydragateway.py" server.start()
05-27-2018 16:44:20.357 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstrap
hydragateway.py" File "/opt/splunk/etc/apps/SA-Hydra/bin/bootstraphydragateway.py", line 30, in
05-27-2018 16:44:20.357 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstrap
hydragateway.py" Traceback (most recent call last):
05-27-2018 16:44:20.357 -0500 ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SA-Hydra/bin/bootstrap
hydra_gateway.py" Enter PEM pass phrase:

I've tried starting splunkweb using a password on the private key and without a password and same error both ways. Obviously the Search head can't connect to schedule anything since port 8008 isn't listening on the Data collector. any ideas what's going on and how to fix? I'm using internal signed CA certs for splunkd and splunkweb and they both work fine other than this ontap add-on. any help is appreciated.

Jason

0 Karma