All Apps and Add-ons

dbxlookup not working in dashboard.


I created a search that uses a dbxlookup command to populate various fields and output a table. This works perfectly in search, but when I add it to a dashboard, all of the lookup fields are empty. The search string is exactly the same.

Has anyone else experienced this?

0 Karma


Was doing some testing to see what shows up in the logs. I noticed that when i click "open in Search" from the dashboard panel, the dbx fields didn't show until I selected verbose mode.

I found this post: and someone sugessted using | fields * to force verbose mode in the dashboard. It worked for me. I'm getting the lookup fields now.

0 Karma

Esteemed Legend

Don't forget to click Answer to close your question.

0 Karma


My initial thought is that this sounds like it may be a permissions related issue.
What version of DBConnect are you running?
Have you checked the DBConnect logs for entries relating to the dbxlookup command? Whatever version of DBConnect you're running check the Troubleshooting section of the documentation to see what is logged and where.
Have you tried setting the DBConnect logging to DEBUG?

Is the dashboard in the same app as your working dbxlookup search?


Revered Legend

+1 on last question.

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!