All Apps and Add-ons

cant setup *nix app: Splunk cannot find "apps/local/unix/setup".

Corey
Explorer

Running spunk 4.2 on rhel 5.5, I added the new *NIX app and when I click on setup I am taken to the following URL:

http://:8000/en-US/manager/unix/apps/local/unix/setup?action=edit

which returns the error

404 Not Found Splunk cannot find "apps/local/unix/setup".

This page was linked to from http://:8000/en-US/manager/launcher/apps/local.

You are using :8000, which is connected to splunkd @96430 at https://127.0.0.1:8089 on Tue Mar 22 15:06:05 2011.

Any ideas? I checked permissions on the file system, every thing is owned by root:root and the directories all have 755 while most the files have 644?

I also checked that I downloaded the newest *NIX app (with 4.2 support)

Best,

Corey

Tags (1)

jackyho
Explorer

I found a rule for this condition.
Splunk seems doesn't give the right control for upgrate of *NIX app (for 4.2) or
any pre-existence app.
If you install an new apps , such as *NIX or any app with setup.xml, It works fine ,but not for upgrate One.

0 Karma

jackyho
Explorer

You can try fallow step:

  1. /opt/splunk/bin/splunk stop

  2. [root@localhost default]# cat app.conf

[install] state = enabled

is_configured = true

build = 96252

[package] id = unix

[ui]

is_visible = true

label = *NIX

[launcher]

author=Splunk, Inc.

description=This is a useful app for helping monitor, manage, and troubleshoot *nix platforms. This app comes with set of scripted inputs for collecting CPU, disk, I/O, memory, log, configuration, and user info. It also provides convenient dashboards, form searches, and alerts to make getting started with Splunk a breeze.

version = 4.2.0

3. [root@localhost default]# cat inputs.conf

[script://./bin/vmstat.sh]

interval = 60

sourcetype = vmstat

source = vmstat

index = os

disabled = 1

..

..

4. /opt/splunk/bin/splunk start

Corey
Explorer

Well, yes. I am able to bypass the setup script by setting the is_configured=true. But what if I actually want to use setup to configure the *NIX app? Has anyone seen this problem before - clicking setup for any app gives a 404 error?

0 Karma

jhansen
Splunk Employee
Splunk Employee

Hi Corey - it seems as though we are unable to duplicate the problem that you are running into. Can you please open a support case and we'll work directly with you to figure out the problem? Once we determine what is happening we can repost here so others are aware of the issue. thanks!

0 Karma

Jason
Motivator

I have also seen this issue as well. Perhaps this might help: Splunk is running as root, and the last app used before going into to the manager to upgrade or install the unix app from scratch was unix, thus the manager URL with two "unix"es in it.

0 Karma

LukeMurphey
Champion

Can you confirm that you have a setup.xml file in the default directory? It should be in:

$SPLUNK_HOME/etc/apps/unix/default/setup.xml
0 Karma

Corey
Explorer

Well, I just installed the Splunk provided *NIX app (for 4.2) from splunkbase. But in looking at the filesystem, "$SPLUNK_HOME/etc/apps/unix/default/setup.xml" does exist, owned by root:root and the permissions are 644

0 Karma
Get Updates on the Splunk Community!

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...

Edge Processor Scaling, Energy & Manufacturing Use Cases, and More New Articles on ...

Splunk Lantern is a Splunk customer success center that provides advice from Splunk experts on valuable data ...

Get More Out of Your Security Practice With a SIEM

Get More Out of Your Security Practice With a SIEMWednesday, July 31, 2024  |  11AM PT / 2PM ETREGISTER ...