All Apps and Add-ons

appserver and http server don't start after ITSI deployment upon Splunk Enterprise

luigitot_dxc
Loves-to-Learn Lots

I’m reaching you submitting  this community thread   because we are stuck in deployment premium app IT Service intelligence on Splunk Enterprise on Prem.

Below troubles we ran into despite  following installation steps:

•  I stopped splunk service
•  I extracted spl ITSI package in according to documentation
•  I ran services but splunkd component wasn’t able to activate appserver and so web server 
Digging either into web_service.log  or mainly into splunkd.log I‘ve found these entries

01-26-2024 17:26:50.164 +0000 ERROR UiPythonFallback [115369 WebuiStartup] - Couldn't start any appserver processes, UI will probably no
t function correctly!
01-26-2024 17:26:50.164 +0000 ERROR UiHttpListener [115369 WebuiStartup] - No app server is running, stop initializing http server.

So I proceeded stopping services , uninstalling app components folders  and its indexes storage repositories (  in according to docs) ; then I ran services again and all components including webservice worked fine .

We ‘ve deployed Splunk enterprise on ubuntu server ( relative package is splunk-9.1.2-b6b9c8185839-linux-2.6-amd64.deb) 
And download ITSI app from its splunkbase link https://splunkbase.splunk.com/app/1841

Could you address with some hints about it ? we 'd try to verify some ITSI features as soon as possible

 

Thanks in advance and regards

 

Luigi

Labels (1)
0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...