All Apps and Add-ons

Why is splunkdj broken for Splunk > 6.0 in Splunk Web Framework Toolkit?

Engager

Using a local install of Splunk on OSX 10.13.4 (High Sierra), I get the following.

$ ./splunkdj setup
Where is Splunk installed (version 5.0 or later is required)? []: /Applications/Splunk/

Setting up the Splunk Web Framework...
The version must be >= 'Splunk 5.0', found 'Splunk 7.1.0 (build 2e75b3406c5b)' in '/Applications/Splunk'. Run 'splunkdj setup' and try again.

Seeing the following lines in appdo.py lines 813-816:

if not (version.startswith("Splunk 5") or version.startswith("Splunk 6") or version.startswith("Splunk 201")):
                os.remove(path.join(MAIN_DIR, ".splunkhome"))
                print "The version must be >= 'Splunk 5.0', found '%s' in '%s'. Run 'splunkdj setup' and try again." % (version, splunk_home)
                sys.exit(1)

So I could be wrong, but it looks to me like this will not run for ANY version 7 of Splunk as written. Has anyone else had this issue?

0 Karma