All Apps and Add-ons

Why JavaBridge starts 1 hour 30 minutes after restarting Splunk?

mrbond
New Member

Hello,

We have strange problem with JavaBridge after restarting Splunk.

JavaBridge starts in about 1 hour 30 minutes after Splunk restarts.
and JavaBridge is working normally.

In logs we didn't see suspicious events.

Can affect the internal processes splunk on such behavior JavaBridge?

Information aboout our splunk installation:
Splunk Version 6.1.1
Splunk Build 207789

JavaBridge server status:
Memory: TOTAL=64.75 MB MAX=227.56 MB FREE=12.82 MB (80% used)

App: dbx version 1.1.4 build 207870
Splunk environment: SplunkEnvironment{SPLUNK_HOME=/opt/splunk,SPLUNK_DB=/opt/splunk/var/lib/splunk}
Splunk version: 6.1.1 build 207789
Java: version: 1.6.0_27 vendor: Sun Microsystems Inc. JAVA_HOME: /usr/lib/jvm/java-6-openjdk-amd64/jre
OS: name: Linux version: 3.2.0-56-generic arch: amd64

DB Connect configuration:
JavaHome: /usr/lib/jvm/java-6-openjdk-amd64/jre/
JVM Commandline options: -Xmx256m -Dfile.encoding=UTF-8 -server -Duser.language=en -Duser.region=

New information for my question.

For update ours apps, we were restarted the splunk.
In dbx.log we found the following strings, maybe they will help in solving problems.

2014-07-29 13:43:36.869 dbx2475:WARN:Shutdown - Performing Java Bridge Server shutdown...
2014-07-29 13:43:36.882 dbx2475:INFO:JavaBridgeServer - ThreadPool shutdown. 0 running tasks have been interrupted
2014-07-29 13:43:36.882 dbx2475:INFO:SplunkContext - Performing Splunk context shutdown...
2014-07-29 13:43:36.882 dbx2475:INFO:Scheduler - Shutting down database inputs...
2014-07-29 13:43:36.883 dbx2475:INFO:Splunkd - Stopping Splunkd REST session keep-alive...
2014-07-29 15:19:48.870 main:INFO:Splunkd - Initialized Splunkd REST service service=127.0.0.1:8089 sessionKey=***************
2014-07-29 15:19:49.161 main:INFO:SplunkContext - Splunk Context initialized: SplunkContext{env=SplunkEnvironment{SPLUNK_HOME=/opt/splunk,SPLUNK_DB=/opt/splunk/var/lib/splunk}}
2014-07-29 15:19:49.536 main:INFO:Splunkd - Scheduling REST session keep-alive with an interval of 5m

As you see between stop and start 1 hour 36 minutes.

0 Karma

splunkIT
Splunk Employee
Splunk Employee

This appears to be a manifestation of a known splunk core issue (SPL-88082), that the splunkd scheduler does not prioritize modular/scripted inputs with interval=0. For db connect, the modular input, which needs to be invoked twice per the design of the modular inputs feature, was being called once and then not being called the second time for an arbitrary length of time. Setting interval to 1 ensures that both calls happen within one second.

Workaround:

  1. Edit $SPLUNK_HOME/etc/apps/dbx/local/inputs.conf
  2. Add "interval =1" for the [script://./bin/jbridge_server.py] stanza:

    [script://./bin/jbridge_server.py]
    disabled = 0
    interval = 1

Finally, Restart splunk

Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...