All Apps and Add-ons
Highlighted

What files contain the configs for Splunk web to do http or https?

Communicator

I have a heavy forwarder on a Win2008 R2 server. After installing the NetApp ONTAP app, Splunk web would only take https connections. I fixed the web.conf file in that app, but Splunk web still will only take https connections. Is there another file which needs to be modified?

Thank you.

Highlighted

Re: What files contain the configs for Splunk web to do http or https?

SplunkTrust
SplunkTrust

enableSplunkWebSSL in web.conf is the place to look at. Use ./bin/splunk cmd btool --debug web list to check where the key's value is coming from.

0 Karma
Highlighted

Re: What files contain the configs for Splunk web to do http or https?

Communicator

Yes. [enableSplunkWebSSL= false] in web.conf but still have to use https to connect to splunk web when launched from local machine.

0 Karma
Highlighted

Re: What files contain the configs for Splunk web to do http or https?

SplunkTrust
SplunkTrust

Did you restart Splunk after the change?
Also, did you just add the square brackets in here or are they also in your conf file?

0 Karma
Highlighted

Re: What files contain the configs for Splunk web to do http or https?

Communicator

Yes, restarted Splunk. No brackets around enableSplunkWebSSL= false.
Also, cleared browser history and restarted server that Splunk is installed on.

0 Karma
Highlighted

Re: What files contain the configs for Splunk web to do http or https?

Communicator

Got it. In the web GUI go to "Settings">"System Settings">"General Settings". About half way down is, "Enable SSL in Splunk Web?", select radio button "No".
Restart.
Problem solved.

Not sure why, but changing the web.conf file worked for 2 of my servers and did not work for the other 2. However, the radio button solution, above, worked.

View solution in original post

Highlighted

Re: What files contain the configs for Splunk web to do http or https?

SplunkTrust
SplunkTrust

The radio button does nothing more than change this web.conf setting... so there must have been an overruling web.conf somewhere, such as etc/ystem/local.

0 Karma