All Apps and Add-ons
Highlighted

Upgrading Splunk Add-on that was build with Splunk Add-on Builder to Python 3

Explorer

We have build an app with Splunk Add-on Builder and it's deployed at our customers Splunk, both self-hosted and cloud deployments.

How should we go about upgrading the Add-on to Python 3 if The Add-on Builder libraries support only Python 2?

Is there a way to force configure our current add-on to use the python 2 interpreter regardless of the Splunk configuration?