All Apps and Add-ons

Talk to Splunk with Amazon Alexa not starting with error "Unable to initialize modular input "alexa"... Introspecting scheme=alexa: script running failed"

keilinw
New Member

Upon a brand new installation as root and starting as root, I get the following error message: Any ideas?

Unable to initialize modular input "alexa" defined inside the app "alexa": Introspecting scheme=alexa: script running failed (exited with code 1).
0 Karma

antlefebvre
Communicator

Be sure you have Java 8+ installed on the system. I installed Java 9 (assuming this fulfilled the 8+ requirement) and got the same error you are seeing. When I backed the Java version down to 8 the error went away and I was able to see the Alexa input.

0 Karma

Damien_Dallimor
Ultra Champion

Have you worked through the troubleshooting steps in the docs

0 Karma
Get Updates on the Splunk Community!

Adoption of RUM and APM at Splunk

    Unleash the power of Splunk Observability   Watch Now In this can't miss Tech Talk! The Splunk Growth ...

March Community Office Hours Security Series Uncovered!

Hello Splunk Community! In March, Splunk Community Office Hours spotlighted our fabulous Splunk Threat ...

Stay Connected: Your Guide to April Tech Talks, Office Hours, and Webinars!

Take a look below to explore our upcoming Community Office Hours, Tech Talks, and Webinars in April. This post ...