All Apps and Add-ons

Talk to Splunk with Amazon Alexa not starting with error "Unable to initialize modular input "alexa"... Introspecting scheme=alexa: script running failed"

keilinw
New Member

Upon a brand new installation as root and starting as root, I get the following error message: Any ideas?

Unable to initialize modular input "alexa" defined inside the app "alexa": Introspecting scheme=alexa: script running failed (exited with code 1).
0 Karma

antlefebvre
Communicator

Be sure you have Java 8+ installed on the system. I installed Java 9 (assuming this fulfilled the 8+ requirement) and got the same error you are seeing. When I backed the Java version down to 8 the error went away and I was able to see the Alexa input.

0 Karma

Damien_Dallimor
Ultra Champion

Have you worked through the troubleshooting steps in the docs

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...