All Apps and Add-ons
Highlighted

Splunk Hadoop Connect installation problem

New Member

I got splunk-hadoop-connect 1.1 from here.

While trying to upload HadoopConnect-1.1-151409.tgz, I get this error on the web UI:
There was an error processing the upload.

I also tried HadoopConnect1.0 and run into same problem. My splunk version is 5.0.3

One thing I noticed, when I tried to untar the file to see whats inside, it gives me error too.

$ tar -xvzf HadoopConnect-1.1-151409.tgz 
tar: Unrecognized archive format: Inappropriate file type or format
tar: Error exit delayed from previous errors.

Can somebody confirm? Sounds like the compressed file is corrupt?

0 Karma
Highlighted

Re: Splunk Hadoop Connect installation problem

Splunk Employee
Splunk Employee

Must be something on your system. I just downloaded the file and untarred it myself:

csharp-mbp15:Downloads csharp$ tar zxvf HadoopConnect-1.1-151409.tgz
HadoopConnect/
HadoopConnect/README/
HadoopConnect/README/export.conf.spec
HadoopConnect/README/clusters.conf.spec
HadoopConnect/README/inputs.conf.spec
...

That's the correct place to grab it, but somehow you're ending up with a corrupt copy. Proxy or firewall doing something to the bits perhaps? Are you sure your web browser isn't automatically un-gziping it? What happens if you just tar xvf and see if maybe its getting uncompressed automatically?

0 Karma