All Apps and Add-ons

Splunk EMC VNX add-on not working


Hi ,

We are trying to configure Splunk Add-on for EMC VNX for VNX block data. We have distributed environment consisting 6 indexers, 2 search heads and 1 heavy forwarder. We installed emc vnx add-on on heavy forwarder and search heads. We also configured input as :

network_addr =
username =
password =
platform = VNX Block
scope = 0
site = SF
index = emc_vnx
disabled = 0

Input is working fine, as we validate with troubleshooting steps.But we are not getting any kind of performance data, also we are getting following exceptions:

2017-06-13 13:22:45,497 ERROR 139829484443392 - Traceback (most recent call last):
File "/opt/splunk/etc/apps/Splunk_TA_emc-vnx/bin/", line 116, in run
File "/opt/splunk/etc/apps/Splunk_TA_emc-vnx/bin/", line 27, in __call
results = self.func()
File "/opt/splunk/etc/apps/Splunk_TA_emc-vnx/bin/", line 406, in collect_perf_metrics
metrics = self.block.collect_perf_metrics()
File "/opt/splunk/etc/apps/Splunk_TA_emc-vnx/bin/", line 51, in collect_perf_metrics
File "/opt/splunk/etc/apps/Splunk_TA_emc-vnx/bin/", line 349, in _get_agents
output = timed_popen(self.cli_common + cli, 15)
File "/opt/splunk/etc/apps/Splunk_TA_emc-vnx/bin/", line 55, in timed_popen
return _do_timed_popen(args, timeout)
File "/opt/splunk/etc/apps/Splunk_TA_emc-vnx/bin/", line 41, in _do_timed_popen
sub = Popen(args, stdout=PIPE, stderr=PIPE)
File "/opt/splunk/lib/python2.7/", line 710, in __init
errread, errwrite)
File "/opt/splunk/lib/python2.7/", line 1335, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory

Can anybody please help with it? Thanks in advance.

Path Finder


Remove Scope from inputs.conf and try loglevel as DEBUG to see performance data in Splunk.

Below inputs works.

network_addr = 10.X.X.X
username = vnxuser
password = vnxpassword
platform = VNX Block
index = emc_vnx
loglevel = DEBUG
site = SF
disabled = 0


0 Karma


We saw something similar with the EMC Isilon app. we had to make an update to correct the scoping of the python script to just the app.

in line 38 of the script it was:
entities = entity.getEntities(['admin', 'passwords'], namespace=myapp, owner='nobody', sessionKey=sessionKey)

we changed it to:
entities = entity.getEntities(['admin', 'passwords'], search=myapp, namespace=myapp, owner='nobody', sessionKey=sessionKey)

and now it works.

See if that helps.


0 Karma


Hi jimodonald,

Thanks for your suggestion. I tried editing and in VNX add-on but it doesn't work. Could you please tell me any another solution.

0 Karma


I tried editing credentials and re installing everything in multiple OS's, I have tried editing many other python scripts but always get the same, I see no one is able to solve this, if you find any solution to this, please let us know! I have tried everything and have lost several hours on this. I am just glad I'm not the only one..

Get Updates on the Splunk Community!

Devesh Logendran, Splunk, and the Singapore Cyber Conquest

At this year’s Splunk University, I had the privilege of chatting with Devesh Logendran, one of the winners in ...

There's No Place Like Chrome and the Splunk Platform

WATCH NOW!Malware. Risky Extensions. Data Exfiltration. End-users are increasingly reliant on browsers to ...

Customer Experience | Join the Customer Advisory Board!

Are you ready to take your Splunk journey to the next level? 🚀 We invite you to join our elite squad ...