All Apps and Add-ons

Splunk DBconnect 3.14 timestamp as rising column failed as ORA-01861: literal does not match format string

tungpx
Loves-to-Learn Everything

Hello,

I tried to input an DB with query as below:

 

SELECT ...,
       txn_stamp as TXTIME,

       ....
FROM mybd
WHERE txn_stamp > ? ORDER BY TXTIME ASC

 

When I hit Excecute query, the result produce error: ORA-01861: literal does not match format string.

My txn_stamp is a time stamp column with the format: YYYY-mm-dd HH:MM:SS (ex: 2023-08-31 00:00:25).

The curious thing is sometime it worked, Executing query show data, but it will stop at some point, I suspect it's because of the above error.

My thinking is I want to formart either my db timestamp formart or the rising column timestamp formart to the same formart so it won't be a mischatch, but I don't know how.

 

Labels (3)
0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...