All Apps and Add-ons

Splunk DB Connect: Why am I unable to use DateTime column as the Index Time?

Hi,
I am using the Splunk DB Connect to connect to an Oracle Database and I want to use the DateTime from one column as the index time.
My SQL search generates a column named "Timestamp_TZ" with sample value as "2016-10-26 05:30:12.0 +1:00" which is in TIMESTAMP format.
At DB-Input settings , I mentioned this column as 'Timestamp Column', 'DateTime Format' is kept blank and Output Timestamp format as "Epoch Time.
I see no errors in dbx2.log but still no data is indexed.
Where I can find this error logs AND is the above configuration correct?

I tried applying other Output Timestamp formats as well, but they all showed error like:

error=ERROR: java.lang.Exception: The datatype of output timestamp column number [2] is invalid as [TIMESTAMP WITH TIME ZONE]..

0 Karma

New Member

Try to add Timestamp format as "yyyy-MM-dd HH:mm:ss.S Z"

0 Karma

DBConnect is not taking it as Timestamp format.
I have also tried : yyyy-MM-dd HH:mm:ss.S XXX as the timezone used is in +1:00 format, but still doesn't work

0 Karma