All Apps and Add-ons

Splunk DB Connect 3.1.1 upgrade now gives Error in 'dbxquery' command

a_salikov
Path Finder

Hello,

When I configured a getting data from Oracle DB I got error after execution query.
Error: Error in 'dbxquery' command: Invalid message received from external search command during setup, see search.log.
DBConnect version is 3.1.1

Please, help me to solve this problem. Thanks!

eduardocrb
Engager

Do your query has "comments"? I faced a similar issue and after replace from "--" to "/* ... */" it solved.

0 Karma

a_salikov
Path Finder

Hi eduardocorb, thanks for your answer, but my query does not has comments. I think that problem in new version 7.0 and I'm waiting for help, because my problem was not solved yet.

gonzaloAgui
Explorer

Hi @a_salikov , I'm facing the same problem right now. Could you solve it? Thanks in advance.

0 Karma

lfedak_splunk
Splunk Employee
Splunk Employee

Hey @markhvesta, your similar post came through the moderation queue, but please follow this post instead. Additional info from @markhvesta:
"The log only references this same generic message, and when setting up the new input, the tables and schema for the new database connection are seen but the error is received before being able to select the input type"

earlhelms
Path Finder

Same issue here. Actually, every search produces the same result. Inputs or ad-hoc. Splunk 7 dbconnect 3.1.1

0 Karma
Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...