All Apps and Add-ons

Splunk DB Connect 2: Why am I getting "Unsupported JRE" for IBM AIX 7.1 using Splunk 6.2.8?

Explorer

Fresh install of Splunk 6.2.8 and latest DB Connect 2. Installed the IBM AIX JRE 1.8

java version "1.8.0"
Java(TM) SE Runtime Environment (build pap3280sr1fp10ifix-20150723_01(SR1 FP10+IV75420))
IBM J9 VM (build 2.8, JRE 1.8.0 AIX ppc-32 20150722_258693 (JIT enabled, AOT enabled)
J9VM - R28_jvm.28_20150722_1718_B258693
JIT  - tr.r14.java_20150625_95081.02
GC   - R28_jvm.28_20150722_1718_B258693
J9CL - 20150722_258693)
JCL - 20150711_01 based on Oracle jdk8u51-b15

But DB Connect setup gives me this error:

JRE Status: Unsupported JRE detected. Using: IBM Corporation JRE version: 1.8 and VM: IBM J9 VM . Need: Oracle Corporation JRE version 1.8

It has worked previously with this same JRE with an older version of DB Connect and 6.1.x of Splunk. I'm guessing that the error is due to DBX looking for a hard-coded version string, and not actually with compatibility of the JRE. Can anyone help?

0 Karma

Splunk Employee
Splunk Employee

The docs here state that you need to have the Oracle JDK 8 Update 31 or later. I would recommend you download and install the Oracle JDK and retest.

I would also suggest you find a new home for your DBConnect deployment, as platform support for AIX for Splunk Enterprise has been removed in 6.3.x. I understand you are on 6.2.8 now, but you will want to upgrade at some point.

0 Karma

Explorer

Thanks for the prompt response! I glazed over that part of the doc since older versions only required the JRE, and on the setup page it specifically asks for the path to the JRE, not JDK. I'll get the JDK installed and hopefully that'll resolve the issue.

Also, we're currently evaluating moving our indexers off of AIX, but in the meantime will be sticking with 6.2.8 until we can vet Linux on PPC or decide to go with RHEL or Windows. It's disappointing that AIX support was removed in 6.3.0.

0 Karma

Explorer

Well I installed the JRE and JDK 8, and now I get this message:
JRE Status: Unsupported JRE detected. Using: IBM Corporation JRE version: 1.0 and VM: IBM J9 VM . Need: Oracle Corporation JRE version 1.8

It's saying IBM version 1.0 now, instead of 1.8 like it did previously... very odd. But I just noticed this in the docs:

Only the Oracle JDK is certified and supported for use with Splunk DB Connect.

I assume this means that IBM's flavor for AIX isn't supported? All the more reason to move off of AIX sooner rather than later, I suppose.

0 Karma

Splunk Employee
Splunk Employee

Your assumption is correct, Only the Oracle JDK is certified and supported. And yes, I would move to a Linux based Splunk deployment.
Your error message suggests that you may not have updated the DBConnect configuration to point at the install location for the Oracle JDK?

0 Karma