All Apps and Add-ons

Splunk App for Content Packs 1.1.0 fails to install invalid app contents

terminaloutcome
Path Finder

When trying to install this app on 8.2.0 (or 8.2.1) I get the following error:

 

 

There was an error processing the upload.Invalid app contents: archive contains more than one immediate subdirectory: and DA-ITSI-CP-microsoft-exchange

 

 

This happens when uploading the downloaded .spl file or installing it automatically from the integrated installer. 

 
Labels (2)
0 Karma

yannK
Splunk Employee
Splunk Employee

The content pack app cannot be installed from the UI. Because it it not one app, but several apps compressed in the same folder.

check the docs : https://docs.splunk.com/Documentation/ITSICP/current/Config/About#Install_the_Splunk_App_for_Content...


You need to access the search-head file system, and untar the app installer in the $SPLUNK_HOME/etc/apps (or on the deployer for SHC)

0 Karma
Get Updates on the Splunk Community!

Platform Highlights | November 2022 Newsletter

 November 2022 Skill Up on Splunk with our New Builder Tech Talk SeriesCan you build it? Yes you can! *play ...

Splunk Education - Fast Start Program!

Welcome to Splunk Education! Splunk training programs are designed to enable you to get started quickly and ...

Five Subtly Different Ways of Adding Manual Instrumentation in Java

You can find the code of this example on GitHub here. Please feel free to star the repository to keep in ...