All Apps and Add-ons

Splunk Add-on for Okta: Why does Splunk not accept SSL certificate?

Engager

Splunk Add-on for Okta API fails from SSL error. Probably due to a proxy changing the certs on the way back in. Splunk does not trust this different cert. I've seen similar problems floating around the web regarding proxies and certs with Splunk. Does anyone have a solution for this?

from internal logs: SSLHandshakeError: [SSL: CERTIFICATEVERIFYFAILED] certificate verify failed

Adding API target IP to the proxy bypass works but I'm trying to figure out a more robust solution.

Path Finder

Hi Bob,
Is this issue resolved. We are getting same SSL handshake error. How did you by pass it with proxy, We are trying with below proxy settings. Do we need to give IP in proxy_url place.

[oktaproxy]
proxy
enabled = 1
proxytype =
proxy
rdns = 1
proxyurl =
proxy
port =
proxyusername =
proxy
password =

0 Karma

Splunk Employee
Splunk Employee

what kind of SSL authentication your proxy requires? I think the problem is due to the fact the the proxy certificate are not trusted on the HWF machine where the add-on runs. I would start by adding the CA root to the trusted store on that machine.

0 Karma