All Apps and Add-ons

Splunk Add-on for Java Management Extensions for jboss 6.3: Why am I getting error "Unsupported protocol: remoting-jmx"?

Murali2888
Communicator

I have an existing jmx_ta app on the forwarder which connects to jboss 5.1.2 version via rmi protocol and polls all the jmx data. We now have few more jboss 6.3 jvms added to the same host which uses remoting-jmx protocol.

<jmxserver host="127.0.0.1" jvmDescription="ABC_1" jmxServiceURL="service:jmx:remoting-jmx://127.0.0.1:9404" jmxuser="xxxx" jmxpass="xxxx" >

However, the jmx.py scripts throws the error systemErrorMessage="Unsupported protocol: remoting-jmx" for the new jvm. I have tried placing jboss-client.jar into the lib directory but still no luck.

Could someone point me to the right direction? I am not sure if I am missing something very obvious.

Thanks for your help.

0 Karma

ofaura
Path Finder
0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>