All Apps and Add-ons

Splunk Add-on for Java Management Extensions for jboss 6.3: Why am I getting error "Unsupported protocol: remoting-jmx"?

Murali2888
Communicator

I have an existing jmx_ta app on the forwarder which connects to jboss 5.1.2 version via rmi protocol and polls all the jmx data. We now have few more jboss 6.3 jvms added to the same host which uses remoting-jmx protocol.

<jmxserver host="127.0.0.1" jvmDescription="ABC_1" jmxServiceURL="service:jmx:remoting-jmx://127.0.0.1:9404" jmxuser="xxxx" jmxpass="xxxx" >

However, the jmx.py scripts throws the error systemErrorMessage="Unsupported protocol: remoting-jmx" for the new jvm. I have tried placing jboss-client.jar into the lib directory but still no luck.

Could someone point me to the right direction? I am not sure if I am missing something very obvious.

Thanks for your help.

0 Karma

ofaura
Path Finder
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...