All Apps and Add-ons

Splunk Add-on for Akamai: Why am I not getting an data when I implement TA_Akamai_SIEM integration?

anzianojackson
Engager

I've been trying to figure this out for a bit now. I've installed the TA_Akamai_SIEM_1.2.0 to ingest Akamai Kona WAF logs. I have tested the REST API via command line to pull SIEM data, but when I trying to implement it with the Splunk Add-on, no data comes back.

Error Message from UI:

Unable to initialize modular input "TA-Akamai_SIEM" defined inside the app "TA-Akamai_SIEM": Introspecting scheme=TA-Akamai_SIEM: script running failed (exited with code 127).

I'm running this on a 6.5.3 forwarder.

0 Karma
1 Solution

cpetterborg
SplunkTrust
SplunkTrust

This is probably caused by java not being installed on the server.

View solution in original post

cpetterborg
SplunkTrust
SplunkTrust

This is probably caused by java not being installed on the server.

View solution in original post

anzianojackson
Engager

I heart you so much!

0 Karma

iamarkaprabha
Contributor

Hi ,

Yes cpetterborg is correct. I had faced the same issue while integrating Akamai and splunk. The main issue is Java path. The shell script was not able to execute the jar due to java path issue

0 Karma

adri2915
Observer

Hello, please, you could say, how resolve this problem? what do you actions you applicated? 

Thank you

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!