All Apps and Add-ons

Splunk Add-on Builder issue

DanAlexander
Communicator

Hi All, I am having an issue using the Splunk Add-on Builder app in a clustered SH environment. I am getting the following Warning error: The Add-on Builder could not be loaded because the current server is in a search head cluster.

Does anyone came across such warning? How this can be fixed? Tried it on a separate SH, but no luck so far. It is in a dev instance. Are there any configs I can adjust on the back end of that SH?

0 Karma

splunkreal
Influencer

Hi @DanAlexander ,

looks like this is not supported at the moment : https://docs.splunk.com/Documentation/AddonBuilder/4.1.4/UserGuide/Installation

"Add-on Builder is not supported in a search head cluster or index cluster environment."

 

You can upvote this idea : https://ideas.splunk.com/ideas/APPSID-I-843

 

 

 

* If this helps, please upvote or accept solution if it solved *
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...