All Apps and Add-ons

Nest Add-on for Splunk: Receiving "Authorization Code Not Found" error when trying to run the command in step 4

New Member

Hello,

I am receiving the following error when attempting to run the command in step 4:

{"error":"oauth2_error","error_description":"authorization code not found","instance_id":"b575b4e8-5b32-4df4-8625-f148beba2141"}

I followed the steps outlined and pasted my auth code into the command. When executing the command, I received the aforementioned error. I tried different auth codes with the same result. I also ran through the troubleshooting steps and was not able to resolve the issue.

Any help would be much appreciated.

Thanks

0 Karma

Builder

I think there may have been an issue with the instructions and how the markdown language formatted it which I just corrected. The error you're receiving usually means you've entered an invalid authorization code. Take a look at the following code sample and note the highlighted section in bold.

curl -X POST "https://api.home.nest.com/oauth2/access_token?client_id=f4151b70-db18-43ac-a12b-1fbcd5f1cba9&code=****&client_secret=mdM3hEligo2PfGBsOMsaHFdvI&grant_type=authorization_code"

You'll want to replace that with the authorization code provided from the following URL

https://home.nest.com/login/oauth2?client_id=f4151b70-db18-43ac-a12b-1fbcd5f1cba9&state=STATE

Then you should receive your access_token.

0 Karma