All Apps and Add-ons

Kafka add-on: Unable to initialize modular input

twinspop
Influencer

The Kafka TA hasn't been updated since before 8 was released. Is it still supported? Running with 8.0.x and 8.1.x I get this error in the search GUI:

    Unable to initialize modular input "kafka_mod" defined in the app "Splunk_TA_kafka": Introspecting scheme=kafka_mod: script running failed (exited with code 1)..

splunkd.log shows

04-06-2021 09:14:08.054 -0400 ERROR ModularInputs - <stderr> Introspecting scheme=kafka_mod: File "/app/splunk/etc/apps/Splunk_TA_kafka/bin/kafka_mod.py", line 67
04-06-2021 09:14:08.054 -0400 ERROR ModularInputs - <stderr> Introspecting scheme=kafka_mod: """.format(c.ta_short_name, desc, kcdl.use_single_instance())
04-06-2021 09:14:08.054 -0400 ERROR ModularInputs - <stderr> Introspecting scheme=kafka_mod: ^
04-06-2021 09:14:08.054 -0400 ERROR ModularInputs - <stderr> Introspecting scheme=kafka_mod: SyntaxError: invalid syntax
04-06-2021 09:14:08.138 -0400 ERROR ModularInputs - Introspecting scheme=kafka_mod: script running failed (exited with code 1).
04-06-2021 09:14:08.138 -0400 ERROR ModularInputs - Unable to initialize modular input "kafka_mod" defined in the app "Splunk_TA_kafka": Introspecting scheme=kafka_mod: script running failed (exited with code 1)..

EDIT: This is a simple case of not wrapping print function in parens, as Python 3 requires. But that tells me this is not Python 3 aware. Seems this TA has been abandoned.

Labels (2)
0 Karma
Get Updates on the Splunk Community!

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...

ICYMI - Check out the latest releases of Splunk Edge Processor

Splunk is pleased to announce the latest enhancements to Splunk Edge Processor.  HEC Receiver authorization ...

Introducing the 2024 SplunkTrust!

Hello, Splunk Community! We are beyond thrilled to announce our newest group of SplunkTrust members!  The ...