All Apps and Add-ons

JMX addon: why is custom script not reading first line jvmdescription?

splunkuzleuven
Loves-to-Learn Lots

Server running Ubuntu 20.04.  Splunk Enterprise 8.2.4.
Splunk Add-on for Java Management Extensions: 5.2.2

I have configured it to use a custom script.
Example output of the script:
splunk_user@server$ mocjmxpids.sh
3267,PROD_process1
2341258,PROD_process2

What will happen when searching the index, is that the field jvmDescription will be correctly filled in with the PID and process name starting from process2 and onwards.
Process1 will not be found and will have the server name as a jvmDescription.  The data from the jmx will be read however, so the addon is attaching to the jvm, just not setting the correct name in jvmDescription.

I honestly don't see what is going wrong.  Same shell is being used for the user, no weird whitespaces I can see?
I have had other issues with the app though, in the sense that the GUI creates a jmx_servers.conf that is invalid.  When selecting customscript, it still creates a pidcommand setting in the file and violates the xml.  So I had to manually rectify the config there already.  This on multiple servers, so I'm wondering if there is more bugged in this version or not.

Labels (1)
Tags (3)
0 Karma
Get Updates on the Splunk Community!

Webinar Recap | Revolutionizing IT Operations: The Transformative Power of AI and ML ...

The Transformative Power of AI and ML in Enhancing Observability   In the realm of IT operations, the ...

.conf24 | Registration Open!

Hello, hello! I come bearing good news: Registration for .conf24 is now open!   conf is Splunk’s rad annual ...

ICYMI - Check out the latest releases of Splunk Edge Processor

Splunk is pleased to announce the latest enhancements to Splunk Edge Processor.  HEC Receiver authorization ...