All Apps and Add-ons

IE8 is not displaying the flashchart if Pulldown module is used

Contributor

Hi,

I encountered a strange problem. IE8 is not displaying the flashchart if I use Puldown module before it. In other browsers it works perfectly. If I remove the Puldown module, the chart is visible also in IE8.
Another observation: if there is a SimpleResultsTable before the flashchart it is visible even if Pulldown module is used.
What could be the reason for this?

Splunk 4.2.4

Sideview Utils 1.2.5

A simplified scenario:

<view autoCancelInterval="90" isPersistable="true" isSticky="false" isVisible="true" objectMode="viewconf" onunloadCancelJobs="true" template="dashboard.html">
<label>Deduplication table</label>
<module name="AccountBar" layoutPanel="appHeader"/>
<module name="AppBar" layoutPanel="appHeader"/>
<module name="SideviewUtils" layoutPanel="appHeader"/>
<module name="TimeRangePicker" layoutPanel="panel_row1_col1" autoRun="True">      
    <param name="default">Last 4 hours</param>   
    <param name="searchWhenChanged">True</param>
        <module name="Pulldown">
            <param name="float">left</param>
            <param name="name">dd</param>
            <param name="label">dd</param>
            <param name="staticFieldsToDisplay">
                <list>
                    <param name="value">*</param>
                    <param name="label">All</param>
                </list>
                <list>
                    <param name="value">none</param>
                    <param name="label">none</param>
                </list>
            </param>
            <module name="SubmitButton">
              <param name="allowSoftSubmit">True</param>
              <module name="Search" layoutPanel="panel_row1_col1" autoRun="True">  
                 <param name="search">index="_internal" | timechart count(host)</param>
                 <module name="HiddenChartFormatter"> 
                   <module name="FlashChart">
                     <param name="width">100%</param>
                     <param name="height">260px</param>
                   </module>
                 </module>
             </module>
         </module>
   </module>
</module>

1 Solution

SplunkTrust
SplunkTrust

The problem is caused by the float param you're using on the Pulldown module. What this param does is create a 'float:left' style on the Pulldown module. With a normal browser this would result in the module after the Pulldown being "floated up" alongside the Pulldown. However Internet Explorer gets confused and decides, instead of pulling the flash movie up alongside the Pulldown, that it will not display the flash movie at all.

It doesn't seem to be serving a particular purpose here so I suspect you don't really want or need that 'float' behavior here. So if you remove that float param your problem will go away. If on the other hand you are trying to do something complex with regards to float styles, send me an email and I'll help you sort it out.

View solution in original post

SplunkTrust
SplunkTrust

Note - you have two autoRun="True" attributes in here, and the second is nested inside the first. You should remove the inner one, as it will cause subtle problems if it isn't already. even if it isn't causing problems, it'll be thrashing the page load a little bit with an extra search dispatch and then a cancellation.

0 Karma

SplunkTrust
SplunkTrust

The problem is caused by the float param you're using on the Pulldown module. What this param does is create a 'float:left' style on the Pulldown module. With a normal browser this would result in the module after the Pulldown being "floated up" alongside the Pulldown. However Internet Explorer gets confused and decides, instead of pulling the flash movie up alongside the Pulldown, that it will not display the flash movie at all.

It doesn't seem to be serving a particular purpose here so I suspect you don't really want or need that 'float' behavior here. So if you remove that float param your problem will go away. If on the other hand you are trying to do something complex with regards to float styles, send me an email and I'll help you sort it out.

View solution in original post

Communicator

I encountered the same problem ago.
The easiest workaround was to insert an empty HTML module right after the PullDown and before the HiddenChartFormatter (or PostProcess):

<![CDATA[< br >< /br >]]>

Line breaks will be invisible on the page and will not allow the child modules to disappear.

0 Karma