All Apps and Add-ons

How can I change the interval time between performance measures?

ssuzano
Engager

Hi,

I'm editing nmon.conf in order to increase the time between measures of performance. Default is:
fifo_interval="60"
fifo_snapshot="1440"

but I wanna change the interval to fifo_interval="180"

The app TA-nmon is installed in my deployment server. After edit nmon.conf file, I run the command
/opt/splunk/bin/splunk reload deploy-server -class serverclassname -debug

I created the nmon.conf in 'local' directory and edited the file there (deployment server). I have edited too the nmon.conf directly in 'default' directory but it haven't work.

My linux servers received the app correctly, and with the new value in fifo_interval parameter, but performance measures are still being collected each 60 seconds.

Do I need to change this parameter in any other file?

Thanks

0 Karma
1 Solution

mwdbhyat
Builder

Hi,

That is the correct file to edit - local should do the trick as it follows the same process and normal Splunk precedence. Have you tried restarting the splunkd service on the forwarder(it should do automatically if your serverclass stanza has restartsplunkd = true).

View solution in original post

0 Karma

mwdbhyat
Builder

Hi,

That is the correct file to edit - local should do the trick as it follows the same process and normal Splunk precedence. Have you tried restarting the splunkd service on the forwarder(it should do automatically if your serverclass stanza has restartsplunkd = true).

View solution in original post

0 Karma

ssuzano
Engager

It was not restarting the splunkd by default.
Tks!

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!